Mini Images: Right Sidebar

  • 11. august 2021

    9 eksempler på bruk av Excel Hvis.

    Excel Hvis, den vanligste av de litt mer avanserte funksjonene i Excel. Hvordan virker den, og hvordan bruke Hvis? 9 Eksempler på akkurat det.


    Hvordan virker hvis?

    Excel funksjonen Hvis består av 3 deler:

    • En logisk test.
    • Hva som skal gjøres når testen er sann, om det stemmer
    • Hva som skal gjøres når det er usant, ikke stemmer.

    Vi kan teste med ulike operatorer og funksjoner, og du kan utføre regneoperasjoner når noe er sant eller usant.

    De vanligste operarorene er:

    =Når A er lik B
    >Når A er større enn B
    <Når A er mindre enn B
    >=Når A større Eller lik B
    <=Når A mindre Eller lik B
    <>Når A er ulik B

    I tillegg kan du blant annet teste på om noe ERTALL, ERTEKST; ERTOM.


    Enkel bruk av Hvis.

    Test om et tall er større enn et annet, med ulikt resultat for sant og usant

    Hvis største tall.
    Hvilket tall er størst.

    Tre varianter som tester om X > Y (ps du kan endre formelen ved å benytte en av de andre operatorene).

    Eksempel 1:

    =HVIS(C4>=C5;»Ja»;»Nei»)

    Hvis skriver Ja om tallet i C4 er større en tallet i C5. Nei hvis det ikke stemmer.

    Eksempel 2:

    =HVIS(C4>C5;B4;B5)

    Vi henter og viser verdien i celle B4 om C4 er større enn C5. Om det ikke er større, henter vi verdien i celle C5.

    Eksempel 3:

    Hvor mye større er X enn Y.

    =HVIS(C4>C5;C4-C5;0)

    Hvis C4 er større enn C5, regner vi ut forskjellen på C4-C5. Hvis ikke skriver vi tallet 0.

    Legg merke til at vi ikke bruker «0», når vi skal ha tall. Bruker du » foran og bak, tolker Excel det som tekst

    Beregne toppskatt med Hvis.

    Beregne toppskatt med Hvis
    Beregne toppskatt med Hvis

    Vi bruker Hvis for å finne ut om inntekten vår er større enn grensen for toppskatt. Hvis den er over, så skal vi beregne toppskatt av forskjellen på vår inntekt og grensen.

    =HVIS(F6>F5;(F6-F5)*F4;0)

    Er inntekten i celle F6 større enn grensen i F5?

    Hvis ja/SANN, regn ut hvor mye 12 prosent er av forskjellen. (F6-F5)*F4. PS. Husk parentesene. Vi må regne ut forskjellen før vi regner ut hvor mye 12% er.


    Hvis i Excel med flere betingelser.

    Excel Hvis - Og Eller
    Excel Hvis – Og Eller

    Vi kan bruke Excel hvis med flere betingelser. Sammen med Eller, når en betingelse skal stemme. Sammen med Og når alle betingelsene skal stemme.

    Du kan kombinere og med Eller om du har mange betingelser. Excel Hvis med flere betingelser, er en måte å gjøre det på. Men det blir fort uoversiktlig, og det er antagelig bedre måter å gjøre det på.

    Excel hvis med Eller.

    Hvis med Eller, så må en av betingelsene stemme, for at Excel utfører det som er angitt i Sann.

    Eksempel:

    =HVIS(ELLER(I4=»Ja»;I6>I5);10000;0)

    Vi skal få bonus om en av flere betingelser stemmer. Om det er «Ja» i celle I4 ELLER tallet i I6 er større enn tallet i I5.. Om en av dem stemmer får vi 10000, hvis ikke blir det 0.

    Excel hvis med Og.

    Når vi bruker Hvis med OG, må alle betingelsene stemme for at det er SANN.

    Eksempel:

    =HVIS(OG(L4=»Ja»;L6>L5);10000;0)

    Her må både L4 = «Ja» OG L6>L5 fort at Excel skal oppgi Sann, og vi vår bonus.


    Andre varianter med Hvis

    I tillegg til de klassiske operatorene kan du teste på resultater av formler, eller en av disse:

    =HVIS(ERTOM(C18:E18);»Ja»;»Nei») – Er sant om cellene i området du er er tomme

    =HVIS(ERTEKST(C19:E19);»Ja»;»Nei») – Er sant om cellene du velger inneholder Tekst

    =HVIS(ERTALL(C20:E20);»Ja»;»Nei») – Er sant om cellene du velger inneholder tall. PS. Datoer er tall, så sjekk med denne om du ville ut om celler inneholder dato.


    Se video:

    9 Eksempler på Excel Hvis

    Om Hogstad Rådgivning.

    Hogstad Rådgivning har lang og god erfaring som kursinstruktør og konsulent. Les mer om hva jeg gjør, eller ta kontakt for en hyggelig samtale.

    By geir Excel
  • 11. august 2021

    Beregne påslag i Excel.

    Påslag er det vi skal tjene på et tilbud. Med utgangspunkt i kostprisen kan du legge til prosent og beregne påslag i Excel.


    Prosentøkning formel i Excel.

    Prisen til kunden er kostpris pluss påslaget. Det enkleste er å gange kostprisen med et desimaltall, der desimalene = prosenten.

    Kostpris * 1,3 tilsvare en økning på 30 prosent, kostpris * 1,03 tilsvarer en økning på 3 prosent.

    Eksempel på formel for prosentøkning: =Kostpris*1,12


    Påslag i prosent ved tilbud.

    Påslag i prosent tilbud
    Påslag i prosent tilbud

    Vi skal øke kostprisen med verdien i en celle. Excel-funksjonen MMULT multipliserer en matrise med en annen matrise. Den første matrisen er listen med priser. Den andre matrisen er området (en celle her) med påslaget

    Formel:

    =MMULT(B16:B20;E14)

    Forklaring:

    MMULT ganger matrisen B16:B20 med matrisen E14. Du får like mange rader som den første matrisen, og like mange kolonner som den andre matrisen.


    Lage en prismatrise med påslag.

    Ofte har vi ulike priser til ulike kundetyper eller kampanjer. Da kan du enkelt lage prismatrise med påslag i Excel for de ulike priskategoriene.

    Formel:

    =MMULT(G3:G7;G11:I11)

    Forklaring:

    Kostprisene er i området G3:G7. De ganges med påslaget som er i området G11 til I11.

    Merk. Du må ha like mange rader i det andre området, som du ha kolonner i det første området. Vi har bare en kolonne G3:G7. Så påslaget for de ulike priskategoriene må stå på en rad.

    Lage prismatrise med påslag.

    Beregne påslag i Excel: Videoinstruksjon:

    I denne videoen viser jeg eksemplene.

    Legge til påslag i Excel

    Om Hogstad rådgivning

    Hogstad rådgivning er en erfaren konsulent og kursinstruktør med spisskompetanse på Excel. Bidrar med kompetanse til profesjonelle og bedrifter.

    Les mer om hva jeg kan hjelpe deg med, eller ta kontakt for en hyggelig samtale.

    By geir Excel
  • 4. august 2021

    Lage et Excel diagram med symboler og emojier.

    Bruk av diagrammer forsterker budskapet titt og engasjerer publikum, Et alternativ\v er å Lage et Excel diagram med symboler og emojier.


    Excel diagram med symboler og emojier.

    For mange er et Excel diagram bare et Excel diagram, for noen er det en mulighet til å forsterke budskapet, engasjere publikum og fortelle sin historie.

    Et klassis diagram i Excel tar ofte mye plass, Da kan det være et alternativ å lage Excel diagramm med symboler og emojier. Det er friskt, og antagelig noe som holder publikum engasjert.


    Excel diagram med symboler

    Når du skal lage et Excel diagram med symboler er knept å benytte en symbol font. Fonter som webdings eller wingdings.

    PS. Det lønner seg å endre fonten til slutt. Så vi kan se hva vi skriver i formellinjen.

    Sett inn symboler i Excel
    Sett inn symboler i Excel

    Slik gjør du:

    • Velg sett inn, og symboler
    • Sett inn symbolet du ønsker
    • Se hvilken bokstav symbolet erstatter.
    • Gjenta bokstaven med denne funksjonen: =gjenta(«g»;C4)
    • endre font il webdings, og farge til ønsket farge.

    I Eksempelet med «g» får du en firkant, som farges blå.


    Lag et diagram med emojier.

    Bruk av emojier i Excel kan gi en morsom effekt, og antagelig imponere publikum.

    I Windows kan du sette inn emojier med å holde Windows-tasten nede, og trykke punktum samtidig.

    Sette inn emojier i Excel
    Sette inn emojier i Excel

    Trykk escape når du har satt inn emojier.

    Igjen bruker du funksjonen gjenta med «». Eksempel:

    =GJENTA(«🏅»;C6)

    Den vil gjenta medaljen det antall ganger som står i cellen C6.


    Videoinstruksjon

    Lag diagram i Excel med emohier og symboler

    Om Hogstad rådgivning

    Hogstad rådgivning har spisskompetanse på Excel. Hjelper bedrifter og profesjonelle med kunnskap, rapport og løsninger. Les mer om tjenestene her:

    By geir Excel
  • 29. juli 2021

    Summer.Hvis.Sett med eller.

    Summer hvis sett summerer vanligvis når 1 eller flere betingelser stemmer. Hva gjør du når en av flere betingelser skal stemme, Summer.Hvis.Sett med eller.

    PS. Dette fungerer også med AntallHvis.sett og gjennomsnitt.hvis.sett


    Summer.hvis.sett
    Summer.hvis.sett

    Summer hvis sett med OG.

    Dette er den vanlige måten å bruker Summer Hvis sette på. Med OG. Det vil si alle betingelsene skal stemme når vi summerer. Selgeren og produktet. Fra dato skal være større enn datoen vi ønsker, OG Til dato mindre enn datoen i rapporten.

    Formel:

    =SUMMER.HVIS.SETT(Tabell1[Omsetning];Tabell1[Selger];H5;Tabell1[Produkt];H6)

    Forklaring:

    Summere tallene i kolonnen for Omsetning, når Kolonne Selger = H5 OG kolonne Vare = H6


    Summer Hvis Sett med ELLER.

    Det er 2 muligheter for eller. Det kan være ELLER i samme kolonne, eller i 2 kolonner.

    Her skal vi summere når det er ELLER i samme kolonner. Selger = kriterium 1 eller Selger = Kriterium 2.

    Formell:

    =SUMMER(SUMMER.HVIS.SETT(Tabell1[Omsetning];Tabell1[Selger];H15:I15))

    Forklaring:

    Summer hvis sett lager en dynamisk matriser der det summerer når kolonne Selger = verdiene i H15 eller I15.

    Summer summere resultatet av matrisen.

    PS. Om du ønsker å se resultatet av hver betingelse, utelater du Summer:

    =SUMMER.HVIS.SETT(Tabell1[Omsetning];Tabell1[Selger];H15:I15)


    Summer hvis sett med Eller i flere kolonner.

    Om du ønsker å summere når noe er i en kolonne eller i en annen kolonne, f.eks. Selger = kriterium ELLER Produkt = kriterium, så er det enklest å plusse to Summer Hvis Sett.

    Formel:

    =SUMMER.HVIS.SETT(Tabell1[Omsetning];Tabell1[Selger];H22) + SUMMER.HVIS.SETT(Tabell1[Omsetning];Tabell1[Produkt];H23)

    Forklaring:

    Vi summerer først resultatet av den første betingelsen, deretter resultatet av den andre betingelsen. Når vi legger dem sammen med + får vi summert når det er betingelse A eller betingelse B.


    Videoeksempel


    Neste steg.

    Hogstad rådgivning har spisskompetanse på Excel, og tilbyr følgende tjenester på Excel.

    By geir Excel
1 2 3 4 5 16
Spisskompetanse er verdifullt.
Øk kompetansen din
Vil du ha hjelp?

Geir Hogstad - Excel entusiast

Send en uforpliktende forespørsel på:  post@365norge.no