Mini Images: Right Sidebar

  • 28. oktober 2021

    Excel Lambda på norsk.

    Excel LAMBDA-funksjonen er en måte å lage egne tilpassede funksjoner som kan gjenbrukes gjennom en arbeidsbok, uten VBA eller makroer.

    Ofte gjentar vi de samme formlene flere steder i det samme regnearket. Med Lambda funksjonen kan du skriver formelen en gang, og gjenta den på en enkel måte.


    Bruk av lambda.

    Det er 2 steg du må gjøre når du skal benytte Lambda:

    • Lage og sjekke formelen.
    • Definere formelen som et navn.

    Lambda eksempler.

    Eksempel på Lambda
    Eksempel på Lambda

    Lambda funksjonen er: =f_summerxogy(C3;C4)

    f_summerxogy er et eget definert navn

    Lambda navnebehandling
    Lambda navnebehandling

    Det refereres til Lambda funksjonen. Lambda funksjonen i Excel har 2 argumenter. Først ett eller flere parametere (navn) som du skal gjøre i den siste delen, beregningen.

    Parameterne i eksemplet er X og Y. Beregningen er X+Y.

    Slik gjør du:

    1. Skriv først selve funksjonen: =Lambda(X;Y;X+Y)
    2. Lambda(X;Y;X+Y) gir en feilmelding når det står alene i regnearket, for det er ingen X og Y. Test den med å skrive =Lambda(X;Y;X+Y)(3;4) – Vill summere 3 og 4.
    3. Kopier Lambda(X;Y;X+Y), lim det inn i Formler, med eget navn. Bruk navnet du har angitt, for å gjenta den samme formelen.

    Lambda videoforklaring.

    For å vise deg hvordan Lambda funger på norsk, kan du se videoforklaringen

    Eksempler på bruk av Lambda

    Last ned regneark med eksempler.

    Til slutt, last ned eksemplene på Lambda her:


    Om Hogstad Rådgivning.

    Excel konsulent Geir Hogstad

    Hogstad rådgivning har høy kompetanse på Excel og tilbyr:

    By geir Excel
  • 24. september 2021

    Fjerne duplikater i Excel med en formel

    Slik kan du fjerne duplikater i Excel med en formel, og få en liste med unike verdier. Oppdag 2 måter å gjøre det på.


    Alternativ 1: Fjern duplikater, behold utseende.

    Fjern duplikater i Excel
    Fjern duplikater i Excel

    Med denne formelen beholder du det samme antall rader i Excel, men duplikater er fjernet, eller erstattet.

    Formel:

    =HVIS(SEKVENS(ANTALLA(B4:B11))=XSAMSVAR(B4:B11;B4:B11);INDEKS(B4:B11;SEKVENS(ANTALLA(B4:B11)));»–«)

    Forklaring:

    Hvis sammenligner resultatet av Sekvens (lager en tallrekke fra 1 til det antall rader som ikke er tomme) med resultatet av Xsamsvar, som lager en liste verdien fra første gangen en tekst dukker opp i liste.

    Når det er sant, viser Indeks resultatet fra listen, når det er usant, vises — eller det du velger innenfor «».

    Video forklaring

    Fjerne duplikater med en formel

    Lag en Unik liste i Excel.

    Lag en unik liste i Excel
    Lag en unik liste i Excel

    Det finnes en egen funksjon i Excel som bare henter en Unik liste. Den kan du benytte i stedet for formelen. Om målet ditt bare er å ha en liste fri for duplikater.

    Formel:

    =UNIK(B4:B11)

    Forklaring:

    Lager en dynamisk liste med unike verdier, fra utvalget. (B4:B11)


    Om Hogstad Rådgivning

    Excel konsulent Geir Hogstad

    Hogstad Rådgivning tilbyr hjelp, løsninger og kurs i Excel. Les mer om hva jeg kan gjøre for deg:

    Klikk her om du vil jeg skal kontakte deg.

    By geir Excel
  • 31. august 2021

    Sammenligne 2 kolonner i Excel.

    Sammenligne 2 kolonner i Excel. For å finne duplikater. Med en enkel formel kan finne hva som er i både kolonne 1 og kolonne 2.


    Formelen for å sammenligne 2 kolonner i Excel.

    Duplikater i 2 lister

    =FILTRER(Tabell2[Navn];ERTALL(XSAMSVAR(Tabell2[Navn];Tabell1[Navn])))

    Formelen for å sammenligne 2 lister eller kolonner i Excel består av 3 steg:

    Steg 1:

    XSAMSVAR(Tabell2[Navn];Tabell1[Navn])

    Forklaring.

    Xsamvar slår opp verdiene i liste 2, og sammenligner med innholdet i liste 1. Reultatet er en lang list, som enten er en feilmelding, eller en tallverdi. Er det en tallverdi, så er innholdet i listene duplikater.

    Steg 2:

    ERTALL(XSAMSVAR(Tabell2[Navn];Tabell1[Navn]))

    Funksjonen Ertall sjekker om resultatet av Xsamsvar er tall. Er det tall, får vi SANN (navnet er i begge listene). Får vi USANN er ikke navnet i begge listene.

    Steg 3:

    =FILTRER(Tabell2[Navn];ERTALL(XSAMSVAR(Tabell2[Navn];Tabell1[Navn])))

    Filtrer viser verdiene i Tabell2 når resultatet av Ertall er SANN.


    Video: Slik finner du duplikater i 2 lister.

    Finne duplikater i lister

    Se videoen der du får se det fra steg til steg.


    Geir Hogstad - Excel ekspert
    Geir Hogstad Excel

    Velkommen til siden min, mitt navn er Geir Hogstad, min jobb er å gjøre din enklere. Bruke tiden bedre i Excel, for å finne det du trenger raskt og presist.

    Tjenester og løsninger:

    .

    By geir Excel
  • 29. august 2021

    Timeliste i Excel per måned

    Skriv timeliste, og la Excel beregne timeliste per måned automatisk. Gjør det selv, eller last ned gratis timeliste i Excel.

    Ps, du kan laste ned malen for timeliste nederst i artikkelen.

    Timeliste per måned i Excel

    Rapporten for timer består av 2 deler:

    • Timeliste
    • En rapport for ønsket måned

    Skriv timeliste.

    Skriv timeliste i Excel
    Skriv timeliste i Excel

    I timelisten fører du hva du gjør. Hvilken dag, klokkeslett for starttidspunktet og sluttidspunktet. Det er alt du skal gjøre. Resten, det skal Excel gjøre. Formatet for dato (med punktum 12.02) og klokkeslett (med kolon 08:00)


    Timeliste per måned.

    Timeliste per måned.
    Timeliste per måned.

    Det tar litt tid å lage en timeliste i Excel, fordi det er mange parametere: Hva er timeprisen, jobber vi natt, er det inkludert lunsj, hvordan behandles overtid.

    Nå som vi har registrert timer i listen, kan vi lage kan du lage en timeliste i Excel per måned.

    Steg 1: Filtrer riktig måned

    =FILTRER(t_timeliste;MÅNED(t_timeliste[Dato])=H8;»Ingen timer»)

    Hva skjer her:

    Filtrer henter radene fra timelisten (t_timeliste) når måneden i datokolonnen = måneden vi velger fra 1 til 12

    Steg 2: har vi jobbet natt?

    Det er ulik beregning på nattvakter. Starter du klokken 9 og slutter 6 dagen etter, har du jobbet 3 timer før midnatt og 6 timer etter. Jobber du dag. Starter 0800 og slutte 1600 kan vi ta 16-8,

    Da kan vi bruke følgende formel:

    =HVIS(H5=»Ja»;HVIS((INDEKS(G11#;;4)-INDEKS(G11#;;3))<0;((24-(INDEKS(G11#;;3)*24))+INDEKS(G11#;;4)24);(INDEKS(G11#;;4)*24)-(INDEKS(G11#;;3))*24);HVIS((INDEKS(G11#;;4)-INDEKS(G11#;;3))<0;((24-(INDEKS(G11#;;3)24))+INDEKS(G11#;;4)*24);(INDEKS(G11#;;4)*24)-(INDEKS(G11#;;3))24)-0,5)

    Sjekk om du jobber natt:

    HVIS((INDEKS(G11#;;4)-INDEKS(G11#;;3))<0

    Er sluttidspunktet – starttidspunktet mindre (>) enn 0

    Regne ute timer før midnatt ( midnatt – start)

    (24-(INDEKS(G11#;;3)*24))+INDEKS(G11#;;4)*24)

    Om ikke trekk starttidspunktet fra slutt tidspunktet

    (INDEKS(G11#;;4)*24)-(INDEKS(G11#;;3)*24

    Betalt lunsj

    =HVIS(H5=»Ja»

    Utfør beregningen for å finne timer

    Hvis ikke: utfør beregningen, trekk fra (-) 0,5

    Beregne timer

    Excel bruker et bestemt format på timer, 06:00 er det samme som 025. 6/24 av døgnet. Det må vi ta hensyn til når vi beregner timer i Excel.

    Jobbet ovetid?

    Har vi jobbet flere timer enn definert normaltid? Da har vi jobbet overtid.

    =HVIS(K11#>$H$2;K11#-$H$2;0)

    Vi trekker normaltiden fra timene vi har jobbet. Om ikke skriver vi 0.

    Beregning av lønn:

    Lønn er lik timeprisen ganger med timene vi gar jobbet, pluss overtidstillegg på timene som er overtid.

    =(K11#$H$4)+(L11#(H4*H3))

    Summer timelisten for måneden.

    Summer kolonnene der du har:

    • Timer; =SUMMER(K11#)
    • Overtid: =SUMMER(L11#)
    • Lønn: =SUMMER(M11#)

    Se video:


    Last ned gratis timeliste mal

    Ps, får du ikke lastet ned med Chrome? Forsøk en annen nettleser, f.eks Edge.


    Alternativet:

    Ønsker du en mer avansert versjon, for flere ansatte og/eller prosjekter? Les mer og Premium versjonen av timelisten her.

    By geir Excel
1 2 3 4 16
Spisskompetanse er verdifullt.
Øk kompetansen din
Vil du ha hjelp?

Geir Hogstad - Excel entusiast

Send en uforpliktende forespørsel på:  post@365norge.no