Fjerne duplikater i Excel med en formel

24. september 2021

Fjerne duplikater i Excel med en formel

Slik kan du fjerne duplikater i Excel med en formel, og få en liste med unike verdier. Oppdag 2 måter å gjøre det på.


Alternativ 1: Fjern duplikater, behold utseende.

Fjern duplikater i Excel
Fjern duplikater i Excel

Med denne formelen beholder du det samme antall rader i Excel, men duplikater er fjernet, eller erstattet.

Formel:

=HVIS(SEKVENS(ANTALLA(B4:B11))=XSAMSVAR(B4:B11;B4:B11);INDEKS(B4:B11;SEKVENS(ANTALLA(B4:B11)));»–«)

Forklaring:

Hvis sammenligner resultatet av Sekvens (lager en tallrekke fra 1 til det antall rader som ikke er tomme) med resultatet av Xsamsvar, som lager en liste verdien fra første gangen en tekst dukker opp i liste.

Når det er sant, viser Indeks resultatet fra listen, når det er usant, vises — eller det du velger innenfor «».

Video forklaring

Fjerne duplikater med en formel

Lag en Unik liste i Excel.

Lag en unik liste i Excel
Lag en unik liste i Excel

Det finnes en egen funksjon i Excel som bare henter en Unik liste. Den kan du benytte i stedet for formelen. Om målet ditt bare er å ha en liste fri for duplikater.

Formel:

=UNIK(B4:B11)

Forklaring:

Lager en dynamisk liste med unike verdier, fra utvalget. (B4:B11)


Om Hogstad Rådgivning

Excel konsulent Geir Hogstad

Hogstad Rådgivning tilbyr hjelp, løsninger og kurs i Excel. Les mer om hva jeg kan gjøre for deg:

Klikk her om du vil jeg skal kontakte deg.

By geir Excel Share:
Spisskompetanse er verdifullt.
Øk kompetansen din
Vil du ha hjelp?

Geir Hogstad - Excel entusiast

Send en uforpliktende forespørsel på:  post@365norge.no