Excel

  • 31 aug
    Sammenligne 2 kolonner i Excel.

    Sammenligne 2 kolonner i Excel.

    Sammenligne 2 kolonner i Excel. For å finne duplikater. Med en enkel formel kan finne hva som er i både kolonne 1 og kolonne 2.


    Formelen for å sammenligne 2 kolonner i Excel.

    Duplikater i 2 lister

    =FILTRER(Tabell2[Navn];ERTALL(XSAMSVAR(Tabell2[Navn];Tabell1[Navn])))

    Formelen for å sammenligne 2 lister eller kolonner i Excel består av 3 steg:

    Steg 1:

    XSAMSVAR(Tabell2[Navn];Tabell1[Navn])

    Forklaring.

    Xsamvar slår opp verdiene i liste 2, og sammenligner med innholdet i liste 1. Reultatet er en lang list, som enten er en feilmelding, eller en tallverdi. Er det en tallverdi, så er innholdet i listene duplikater.

    Steg 2:

    ERTALL(XSAMSVAR(Tabell2[Navn];Tabell1[Navn]))

    Funksjonen Ertall sjekker om resultatet av Xsamsvar er tall. Er det tall, får vi SANN (navnet er i begge listene). Får vi USANN er ikke navnet i begge listene.

    Steg 3:

    =FILTRER(Tabell2[Navn];ERTALL(XSAMSVAR(Tabell2[Navn];Tabell1[Navn])))

    Filtrer viser verdiene i Tabell2 når resultatet av Ertall er SANN.


    Video: Slik finner du duplikater i 2 lister.

    Finne duplikater i lister

    Se videoen der du får se det fra steg til steg.


    Geir Hogstad - Excel ekspert
    Geir Hogstad Excel

    Velkommen til siden min, mitt navn er Geir Hogstad, min jobb er å gjøre din enklere. Bruke tiden bedre i Excel, for å finne det du trenger raskt og presist.

    Tjenester og løsninger:

    .

    By geir Excel
  • 29 aug
    Timeliste i Excel per måned

    Timeliste i Excel per måned

    Skriv timeliste, og la Excel beregne timeliste per måned automatisk. Gjør det selv, eller last ned gratis timeliste i Excel.

    Ps, du kan laste ned malen for timeliste nederst i artikkelen.

    Timeliste per måned i Excel

    Rapporten for timer består av 2 deler:

    • Timeliste
    • En rapport for ønsket måned

    Skriv timeliste.

    Skriv timeliste i Excel
    Skriv timeliste i Excel

    I timelisten fører du hva du gjør. Hvilken dag, klokkeslett for starttidspunktet og sluttidspunktet. Det er alt du skal gjøre. Resten, det skal Excel gjøre. Formatet for dato (med punktum 12.02) og klokkeslett (med kolon 08:00)


    Timeliste per måned.

    Timeliste per måned.
    Timeliste per måned.

    Det tar litt tid å lage en timeliste i Excel, fordi det er mange parametere: Hva er timeprisen, jobber vi natt, er det inkludert lunsj, hvordan behandles overtid.

    Nå som vi har registrert timer i listen, kan vi lage kan du lage en timeliste i Excel per måned.

    Steg 1: Filtrer riktig måned

    =FILTRER(t_timeliste;MÅNED(t_timeliste[Dato])=H8;»Ingen timer»)

    Hva skjer her:

    Filtrer henter radene fra timelisten (t_timeliste) når måneden i datokolonnen = måneden vi velger fra 1 til 12

    Steg 2: har vi jobbet natt?

    Det er ulik beregning på nattvakter. Starter du klokken 9 og slutter 6 dagen etter, har du jobbet 3 timer før midnatt og 6 timer etter. Jobber du dag. Starter 0800 og slutte 1600 kan vi ta 16-8,

    Da kan vi bruke følgende formel:

    =HVIS(H5=»Ja»;HVIS((INDEKS(G11#;;4)-INDEKS(G11#;;3))<0;((24-(INDEKS(G11#;;3)*24))+INDEKS(G11#;;4)24);(INDEKS(G11#;;4)*24)-(INDEKS(G11#;;3))*24);HVIS((INDEKS(G11#;;4)-INDEKS(G11#;;3))<0;((24-(INDEKS(G11#;;3)24))+INDEKS(G11#;;4)*24);(INDEKS(G11#;;4)*24)-(INDEKS(G11#;;3))24)-0,5)

    Sjekk om du jobber natt:

    HVIS((INDEKS(G11#;;4)-INDEKS(G11#;;3))<0

    Er sluttidspunktet – starttidspunktet mindre (>) enn 0

    Regne ute timer før midnatt ( midnatt – start)

    (24-(INDEKS(G11#;;3)*24))+INDEKS(G11#;;4)*24)

    Om ikke trekk starttidspunktet fra slutt tidspunktet

    (INDEKS(G11#;;4)*24)-(INDEKS(G11#;;3)*24

    Betalt lunsj

    =HVIS(H5=»Ja»

    Utfør beregningen for å finne timer

    Hvis ikke: utfør beregningen, trekk fra (-) 0,5

    Beregne timer

    Excel bruker et bestemt format på timer, 06:00 er det samme som 025. 6/24 av døgnet. Det må vi ta hensyn til når vi beregner timer i Excel.

    Jobbet ovetid?

    Har vi jobbet flere timer enn definert normaltid? Da har vi jobbet overtid.

    =HVIS(K11#>$H$2;K11#-$H$2;0)

    Vi trekker normaltiden fra timene vi har jobbet. Om ikke skriver vi 0.

    Beregning av lønn:

    Lønn er lik timeprisen ganger med timene vi gar jobbet, pluss overtidstillegg på timene som er overtid.

    =(K11#$H$4)+(L11#(H4*H3))

    Summer timelisten for måneden.

    Summer kolonnene der du har:

    • Timer; =SUMMER(K11#)
    • Overtid: =SUMMER(L11#)
    • Lønn: =SUMMER(M11#)

    Se video:


    Last ned gratis timeliste mal

    Ps, får du ikke lastet ned med Chrome? Forsøk en annen nettleser, f.eks Edge.


    Alternativet:

    Ønsker du en mer avansert versjon, for flere ansatte og/eller prosjekter? Les mer og Premium versjonen av timelisten her.

    By geir Excel
  • 11 aug
    9 eksempler på bruk av Excel Hvis.

    9 eksempler på bruk av Excel Hvis.

    Excel Hvis, den vanligste av de litt mer avanserte funksjonene i Excel. Hvordan virker den, og hvordan bruke Hvis? 9 Eksempler på akkurat det.


    Hvordan virker hvis?

    Excel funksjonen Hvis består av 3 deler:

    • En logisk test.
    • Hva som skal gjøres når testen er sann, om det stemmer
    • Hva som skal gjøres når det er usant, ikke stemmer.

    Vi kan teste med ulike operatorer og funksjoner, og du kan utføre regneoperasjoner når noe er sant eller usant.

    De vanligste operarorene er:

    =Når A er lik B
    >Når A er større enn B
    <Når A er mindre enn B
    >=Når A større Eller lik B
    <=Når A mindre Eller lik B
    <>Når A er ulik B

    I tillegg kan du blant annet teste på om noe ERTALL, ERTEKST; ERTOM.


    Enkel bruk av Hvis.

    Test om et tall er større enn et annet, med ulikt resultat for sant og usant

    Hvis største tall.
    Hvilket tall er størst.

    Tre varianter som tester om X > Y (ps du kan endre formelen ved å benytte en av de andre operatorene).

    Eksempel 1:

    =HVIS(C4>=C5;»Ja»;»Nei»)

    Hvis skriver Ja om tallet i C4 er større en tallet i C5. Nei hvis det ikke stemmer.

    Eksempel 2:

    =HVIS(C4>C5;B4;B5)

    Vi henter og viser verdien i celle B4 om C4 er større enn C5. Om det ikke er større, henter vi verdien i celle C5.

    Eksempel 3:

    Hvor mye større er X enn Y.

    =HVIS(C4>C5;C4-C5;0)

    Hvis C4 er større enn C5, regner vi ut forskjellen på C4-C5. Hvis ikke skriver vi tallet 0.

    Legg merke til at vi ikke bruker «0», når vi skal ha tall. Bruker du » foran og bak, tolker Excel det som tekst

    Beregne toppskatt med Hvis.

    Beregne toppskatt med Hvis
    Beregne toppskatt med Hvis

    Vi bruker Hvis for å finne ut om inntekten vår er større enn grensen for toppskatt. Hvis den er over, så skal vi beregne toppskatt av forskjellen på vår inntekt og grensen.

    =HVIS(F6>F5;(F6-F5)*F4;0)

    Er inntekten i celle F6 større enn grensen i F5?

    Hvis ja/SANN, regn ut hvor mye 12 prosent er av forskjellen. (F6-F5)*F4. PS. Husk parentesene. Vi må regne ut forskjellen før vi regner ut hvor mye 12% er.


    Hvis i Excel med flere betingelser.

    Excel Hvis - Og Eller
    Excel Hvis – Og Eller

    Vi kan bruke Excel hvis med flere betingelser. Sammen med Eller, når en betingelse skal stemme. Sammen med Og når alle betingelsene skal stemme.

    Du kan kombinere og med Eller om du har mange betingelser. Excel Hvis med flere betingelser, er en måte å gjøre det på. Men det blir fort uoversiktlig, og det er antagelig bedre måter å gjøre det på.

    Excel hvis med Eller.

    Hvis med Eller, så må en av betingelsene stemme, for at Excel utfører det som er angitt i Sann.

    Eksempel:

    =HVIS(ELLER(I4=»Ja»;I6>I5);10000;0)

    Vi skal få bonus om en av flere betingelser stemmer. Om det er «Ja» i celle I4 ELLER tallet i I6 er større enn tallet i I5.. Om en av dem stemmer får vi 10000, hvis ikke blir det 0.

    Excel hvis med Og.

    Når vi bruker Hvis med OG, må alle betingelsene stemme for at det er SANN.

    Eksempel:

    =HVIS(OG(L4=»Ja»;L6>L5);10000;0)

    Her må både L4 = «Ja» OG L6>L5 fort at Excel skal oppgi Sann, og vi vår bonus.


    Andre varianter med Hvis

    I tillegg til de klassiske operatorene kan du teste på resultater av formler, eller en av disse:

    =HVIS(ERTOM(C18:E18);»Ja»;»Nei») – Er sant om cellene i området du er er tomme

    =HVIS(ERTEKST(C19:E19);»Ja»;»Nei») – Er sant om cellene du velger inneholder Tekst

    =HVIS(ERTALL(C20:E20);»Ja»;»Nei») – Er sant om cellene du velger inneholder tall. PS. Datoer er tall, så sjekk med denne om du ville ut om celler inneholder dato.


    Se video:

    9 Eksempler på Excel Hvis

    Om Hogstad Rådgivning.

    Hogstad Rådgivning har lang og god erfaring som kursinstruktør og konsulent. Les mer om hva jeg gjør, eller ta kontakt for en hyggelig samtale.

    By geir Excel
  • 11 aug
    Beregne påslag i Excel.

    Beregne påslag i Excel.

    Påslag er det vi skal tjene på et tilbud. Med utgangspunkt i kostprisen kan du legge til prosent og beregne påslag i Excel.


    Prosentøkning formel i Excel.

    Prisen til kunden er kostpris pluss påslaget. Det enkleste er å gange kostprisen med et desimaltall, der desimalene = prosenten.

    Kostpris * 1,3 tilsvare en økning på 30 prosent, kostpris * 1,03 tilsvarer en økning på 3 prosent.

    Eksempel på formel for prosentøkning: =Kostpris*1,12


    Påslag i prosent ved tilbud.

    Påslag i prosent tilbud
    Påslag i prosent tilbud

    Vi skal øke kostprisen med verdien i en celle. Excel-funksjonen MMULT multipliserer en matrise med en annen matrise. Den første matrisen er listen med priser. Den andre matrisen er området (en celle her) med påslaget

    Formel:

    =MMULT(B16:B20;E14)

    Forklaring:

    MMULT ganger matrisen B16:B20 med matrisen E14. Du får like mange rader som den første matrisen, og like mange kolonner som den andre matrisen.


    Lage en prismatrise med påslag.

    Ofte har vi ulike priser til ulike kundetyper eller kampanjer. Da kan du enkelt lage prismatrise med påslag i Excel for de ulike priskategoriene.

    Formel:

    =MMULT(G3:G7;G11:I11)

    Forklaring:

    Kostprisene er i området G3:G7. De ganges med påslaget som er i området G11 til I11.

    Merk. Du må ha like mange rader i det andre området, som du ha kolonner i det første området. Vi har bare en kolonne G3:G7. Så påslaget for de ulike priskategoriene må stå på en rad.

    Lage prismatrise med påslag.

    Beregne påslag i Excel: Videoinstruksjon:

    I denne videoen viser jeg eksemplene.

    Legge til påslag i Excel

    Om Hogstad rådgivning

    Hogstad rådgivning er en erfaren konsulent og kursinstruktør med spisskompetanse på Excel. Bidrar med kompetanse til profesjonelle og bedrifter.

    Les mer om hva jeg kan hjelpe deg med, eller ta kontakt for en hyggelig samtale.

    By geir Excel
1 2 3 4 11
Spisskompetanse er verdifullt.
Øk kompetansen din
Vil du ha hjelp?

Geir Hogstad - Excel entusiast

Send en uforpliktende forespørsel på:  post@365norge.no