9 eksempler på bruk av Excel Hvis.

11. august 2021

9 eksempler på bruk av Excel Hvis.

Excel Hvis, den vanligste av de litt mer avanserte funksjonene i Excel. Hvordan virker den, og hvordan bruke Hvis? 9 Eksempler på akkurat det.


Hvordan virker hvis?

Excel funksjonen Hvis består av 3 deler:

  • En logisk test.
  • Hva som skal gjøres når testen er sann, om det stemmer
  • Hva som skal gjøres når det er usant, ikke stemmer.

Vi kan teste med ulike operatorer og funksjoner, og du kan utføre regneoperasjoner når noe er sant eller usant.

De vanligste operarorene er:

=Når A er lik B
>Når A er større enn B
<Når A er mindre enn B
>=Når A større Eller lik B
<=Når A mindre Eller lik B
<>Når A er ulik B

I tillegg kan du blant annet teste på om noe ERTALL, ERTEKST; ERTOM.


Enkel bruk av Hvis.

Test om et tall er større enn et annet, med ulikt resultat for sant og usant

Hvis største tall.
Hvilket tall er størst.

Tre varianter som tester om X > Y (ps du kan endre formelen ved å benytte en av de andre operatorene).

Eksempel 1:

=HVIS(C4>=C5;»Ja»;»Nei»)

Hvis skriver Ja om tallet i C4 er større en tallet i C5. Nei hvis det ikke stemmer.

Eksempel 2:

=HVIS(C4>C5;B4;B5)

Vi henter og viser verdien i celle B4 om C4 er større enn C5. Om det ikke er større, henter vi verdien i celle C5.

Eksempel 3:

Hvor mye større er X enn Y.

=HVIS(C4>C5;C4-C5;0)

Hvis C4 er større enn C5, regner vi ut forskjellen på C4-C5. Hvis ikke skriver vi tallet 0.

Legg merke til at vi ikke bruker «0», når vi skal ha tall. Bruker du » foran og bak, tolker Excel det som tekst

Beregne toppskatt med Hvis.

Beregne toppskatt med Hvis
Beregne toppskatt med Hvis

Vi bruker Hvis for å finne ut om inntekten vår er større enn grensen for toppskatt. Hvis den er over, så skal vi beregne toppskatt av forskjellen på vår inntekt og grensen.

=HVIS(F6>F5;(F6-F5)*F4;0)

Er inntekten i celle F6 større enn grensen i F5?

Hvis ja/SANN, regn ut hvor mye 12 prosent er av forskjellen. (F6-F5)*F4. PS. Husk parentesene. Vi må regne ut forskjellen før vi regner ut hvor mye 12% er.


Hvis i Excel med flere betingelser.

Excel Hvis - Og Eller
Excel Hvis – Og Eller

Vi kan bruke Excel hvis med flere betingelser. Sammen med Eller, når en betingelse skal stemme. Sammen med Og når alle betingelsene skal stemme.

Du kan kombinere og med Eller om du har mange betingelser. Excel Hvis med flere betingelser, er en måte å gjøre det på. Men det blir fort uoversiktlig, og det er antagelig bedre måter å gjøre det på.

Excel hvis med Eller.

Hvis med Eller, så må en av betingelsene stemme, for at Excel utfører det som er angitt i Sann.

Eksempel:

=HVIS(ELLER(I4=»Ja»;I6>I5);10000;0)

Vi skal få bonus om en av flere betingelser stemmer. Om det er «Ja» i celle I4 ELLER tallet i I6 er større enn tallet i I5.. Om en av dem stemmer får vi 10000, hvis ikke blir det 0.

Excel hvis med Og.

Når vi bruker Hvis med OG, må alle betingelsene stemme for at det er SANN.

Eksempel:

=HVIS(OG(L4=»Ja»;L6>L5);10000;0)

Her må både L4 = «Ja» OG L6>L5 fort at Excel skal oppgi Sann, og vi vår bonus.


Andre varianter med Hvis

I tillegg til de klassiske operatorene kan du teste på resultater av formler, eller en av disse:

=HVIS(ERTOM(C18:E18);»Ja»;»Nei») – Er sant om cellene i området du er er tomme

=HVIS(ERTEKST(C19:E19);»Ja»;»Nei») – Er sant om cellene du velger inneholder Tekst

=HVIS(ERTALL(C20:E20);»Ja»;»Nei») – Er sant om cellene du velger inneholder tall. PS. Datoer er tall, så sjekk med denne om du ville ut om celler inneholder dato.


Se video:

9 Eksempler på Excel Hvis

Om Hogstad Rådgivning.

Hogstad Rådgivning har lang og god erfaring som kursinstruktør og konsulent. Les mer om hva jeg gjør, eller ta kontakt for en hyggelig samtale.

By geir Excel Share:
Spisskompetanse er verdifullt.
Øk kompetansen din
Vil du ha hjelp?

Geir Hogstad - Excel entusiast

Send en uforpliktende forespørsel på:  post@365norge.no