3 måter å bruke forskyvning på.

25. juli 2021

3 måter å bruke forskyvning på.

3 måter å bruke forskyvning på. som vil imponere deg selv og kollegene dine.. Finn største tallet, gjennomsnittet og summer de 3 siste månedene.


Forskyvning, dronningen av Excel Funksjoner.

Om Excel funksjoner var sjakkbrikker, ville Forskyvning vært dronningen, den kan gå i alle retninger, når du skal beskrive området i regnearket du skal beregne fra.

Eksempel forskyvning: Finn de 3 siste månedene.

Excel funksjonen forskyvning.
Gjennomsnitt måneder i Excel

Excel funksjonen Forskyvning

En kolonne for hver måned, med Forskyvning, og litt hjelp finner vi kolonnene som inkluderer de 3 siste månedene.

Excel funksjonen har et startpunkt. Fra det oppgitte startpunktet teller vi oss frem hvor våre data starter. Med å oppgi rader og kolonner. Så kan du oppgi hvor stort områder er. Antall rader, (høyde) og antall kolonner (bredde). Du kan bruke både positive tall og negative tall for å oppgi området.

Formel:

=FORSKYVNING(A11;1;ANTALL(B12:M12);8;-3)

Forklaring:

  • A11, er startpunktet hvor vi skal telle fra.
  • 1 er antall rader ned hvor tallene våre starter
  • Antall(B12:M12) teller hvor mange kolonner som har tall, det er det samme som antallet vi skal bevege oss til høyre.
  • 8 er antall rader ned med tall
  • -3 er antall kolonner vi skal telle tilbake. (for å få siste 3 måneder)

Nå har vi en dynamisk matrise med tall. Den matrisen kan vi bruke til det vi ønsker.

Finn gjennomsnittet av de 3 siste månedene.

Bruk resultatet fra forskyvning, og legg til funksjonen Gjennomsnitt.

=GJENNOMSNITT(FORSKYVNING(A11;1;ANTALL(B12:M12);8;-3))

Finn det største tallet de 3 siste månedene.

Ofte er vi på jakt etter det største talle, funksjonen for å finne det største tallet er Størst.

=Størst(FORSKYVNING(A11;1;ANTALL(B12:M12);8;-3))

Summer de 3 siste månedene.

Summer summerer det området vi ønsker, og du kan bruk Summer på dynamiske matriser.

=Summer(FORSKYVNING(A11;1;ANTALL(B12:M12);8;-3))


Videoforklaring.

Excel funksjonen forskyvning

Lær mer og forskyvning og dynamiske matriser.

En av hemmelighetene med å lage gode analyser og rapport i Excel, er å kunne identifisere det området vi skal analysere.

Dette eksemplet er fra kurset «Analyse i Excel», les mer her.


Om Hogstad Rådgivning.

Hogstad Rådgivning har spisskompetanse på Excel, og tilbyr:

By geir Excel Share:
Spisskompetanse er verdifullt.
Øk kompetansen din
Vil du ha hjelp?

Geir Hogstad - Excel entusiast

Send en uforpliktende forespørsel på:  post@365norge.no