10 Excel funksjoner du bør kunne.

4. september 2020

10 Excel funksjoner du bør kunne.

Excel gir deg et hav av muligheter og detter er 10 Excel funksjoner du bør kunne. Klassiske funksjoner og nye matriseformler du kanskje ikke har sett før. Noen av matrisefunksjonene vil endre måten du bruker Excel på, for alltid.

Du kan laste ned eksemplene på disse Excel-funksjonene nederst i artikkelen.


10 nyttige formler i Excel.

Hva som er nyttige formler i Excel vil variere. Noen bruker Excel til å knuse tall og lage analyser. Noen jobber med store datalister og vil ha oversikt. Her er 10 nyttige formler i Excel som du bør kunne.


Excel funksjonen Hvis

Excel funksjonen Hvis
Excel funksjonen Hvis

Excel funksjonen Hvis bruker du for å utføre en ønsket handling i Excel når noe stemmer, eller ikke stemmer. Er vi over budsjett så, hvis ikke så.

Formel:

=HVIS(D5>C5;»Over budsjett»;»Under budsjett»)

Forklaring:

Vi sjekker om Salget (celle D5) er større (>) enn Budsjett (C5) og utfører handlingen «Over Budsjett» om det stemmer, «Under Budsjett» om det ikke stemmer.

Les mer om og se flere eksempler på Hvis her.


Excel funksjonen Unik – Matriseformel

Excel funksjonen Unik
Excel funksjonen Unik

Unik er matrisefunksjon. Og gir oss en oversikt over unike verdier i en liste, eller kolonne.

Formel:

=UNIK(B4:B22)

Forklaring:

Gir oss en unik oversikt over alle selgerne i området (B4:B22)


Excel funksjonen Filtrer – Matriseformel

Excel funksjonen Filtrer
Excel funksjonen Filtrer

Filtrer er en matrisefunksjon, og gir oss en ny liste basert på ett eller flere kriterier. Hvilke kolonner du skal vise i den dynamiske listen Filtrer generer velger du selv.

Formel:

=FILTRER(B3:C22;C3:C22>4000),

Forklaring:

Viser radene i området (B3:C22) der verdiene i (C3:C22) er større (>) enn 4000.


Excel funksjonen Hvis.feil

Excel funksjonen Hvis.feil
Excel funksjonen Hvis.feil

Når vi bruker Excel er det ikke til å unngå at vi noen ganger opplever feilmeldinger. Noen ganger er det feil i funksjonen andre ganger stemmer ikke resultatet. Som når vi forsøker å dele noe på 0. Det går ikke opp, i stedet for feilmeldingen #Div/0!, som ser rotet ut, kan vi gi en beskjes om hva som er feil.

Formel:

=HVISFEIL(B10/A10;»Mangler antall»)

Forklaring:

Deler B1= med verdien i A10. Hvis det er feil (#Div/0!) så skriver Excel «Mangler antall».


Excel funksjonen Sorter – Matriseformel

Sorter er en ny matriseformel i Excel. Det gir en ny dynamisk liste sortert på det vi ønsker. Du kan sortere alfabetisk, numerisk. Stigende eller synkende. Og du sortere på den kolonnen du selv ønsker.

Excel funksjonen Sorter
Excel funksjonen Sorter

Formel:

=SORTER(A4:C13;3;-1)

Forklaring:

Sorterer området (A3:C13) på kolonne (3) synkende (-1). Bruker vi (1) vil den sortere stigende.


Excel funksjonen Xoppslag

Excel funksjonen Xoppslag
Excel funksjonen Xoppslag

Xoppslag slår opp verdier i en dataliste. I motsetning til Finn.Rad, Indeks og Sammenligne kan Xoppslag finne verdier i en celle bød når du spesifiser søkeverdi i rader, og kolonner. I tillegg er den mye enklere å bruke.

Formel:

=XOPPSLAG(F7;A5:A9;D5:D9)

Forklaring:

Søker etter navn på selger (F7), i området (A5:A9) og returnerer verdien fra raden som er i området (D5:D9)

Formel:

=XOPPSLAG(F10;A4:D4;A7:D7)

Forklaring:

Søker etter Antall i området for overskrifter (A4:D4), or slår opp verdien for selger Hansen (A7:D7)


Excel funksjonen Antall.Hvis.Sett

Antall.Hvis.Sett
Antall.Hvis.Sett

Formel:

=ANTALL.HVIS.SETT(B5:B12;F7)

Forklaring:

Teller hvor mange ganger Hansen (F7) finnes i listen (B5:B12).


Excel funksjonen Summer.Hvis.Sett

Excel funksjonen Summer hvis sett
Excel funksjonen Summer hvis sett

Summer hvis sett legger sammen alle verdiene i et område basert på et, eller flere vilkår som du angir. Summer.hvis sett kan brukes som en matrisefunksjon. Det vil si at området du finne verdier i kan endre seg dynamisk, når listen vokser, minsker eller endres.

Formel:

=SUMMER.HVIS.SETT(C4:C11;A4:A11;E7)

Forklaring:

Summerer verdiene i området (C4:C11) når det som er i området (A4:A11) stemmer med riktig selger, spesifisert i (E7)


Excel funksjonen søk

Excel funksjonen søk
Excel funksjonen søk

Søk leter etter en verdi du angir, og returnerer et tall om det finnes i søkeområdet. Tallverdien er startposisjonen på det du søker etter. Finnes ikke det du søker får du feilmelding #Verdi!. Kombiner med Hvisfeil, for å gi en bedre melding.

Formel:

=SØK(«IS»;C5)

Forklaring:

Viser 1 i rad 5, fordi «Is» starter i posisjon 1. I Rad 8 starter «Is» i posisjon 5.

Tips:

Bruk * for å søke etter noen som inneholder is (*is*)


Er-funksjoner

 funksjoner i Excel
funksjoner i Excel

ERTOM, ERTALL, ERTEKST er funksjoner vi kan bruke for å finne ut nettopp det. Brukes gjerne sammen med andre funksjoner som Hvis

Formel

=ERTOM(B1)

Forklaring:

Sjekker om innholdet i B1 er tomt. Hvis det er tomt returnerer Excel SANN. Hvis ikke blir svaret USANN.

Formel

=ERTALL(B1)

Forklaring:

Sjekker om innholdet i B1 er tall. Hvis det er tall returnerer Excel SANN. Hvis ikke blir svaret USANN.

Formel

=ERTEKST(B1)

Forklaring:

Sjekker om innholdet i B1 er tekst. Hvis det er tekst returnerer Excel SANN. Hvis ikke blir svaret USANN.


Lære mer Excel, eller få bistand.

Vil du bli flinkere i Excel. Lære mer på kurs, eller lære når du får hjelp med problemet ditt? Det finnes et hav av mulighet når du velger og kan riktige Excel funksjoner.


Neste steg

Få hjelp med Excel nå. Ofte den beste måten å lære på.

Kan du litt Excel, og vil bli god. Excel kurs for viderekommende.

Lær de 4 vanligste funksjonene i Excel gratis


Last ned eksempler på Excel funksjoner.

Last ned eksemplene på Excel-funksjonene som er beskrevet i artikkelen.

Last ned uten registrering. Ps. Får du ikke lastet med Chrome forsøk med Edge.

By geir Excel Share:
Spisskompetanse er verdifullt.
Øk kompetansen din
Vil du ha hjelp?

Geir Hogstad - Excel entusiast

Send en uforpliktende forespørsel på:  post@365norge.no