Excel celler med tekst

24. februar 2018

Excel celler med tekst

Summere celler med tekst i Excel. Her er 5 eksempler på hvordan du kan summere og telle celler med tekst i Excel. Smarte måter å finne riktig tall og antall på, når du skal telle antall forekomster og summere hvis noe stemmer.

Tallene vi skal summere i Excel er ofte basert på celler med tekst. På kurs jeg holder er det en gjenganger. Finne verdier i personal-lister, og når vi skal se på salg og budsjett.

Våren og påsken nærmer seg. Jeg har et godt tilbud til deg, få tid til overs. Nå får du 50% på Excel hjelp og online kurs. Se mer her.

I Excel-eksemplene under skal vi se på:

  • Antall.Hvis
  • Antall.Hvis.Sett
  • SummerHvis
  • Summer.Hvis.Sett
  • Summerprodukt




Summer tekst i Excel

Med telle eksempler

excel antall

Tell hvor ofte en verdi forekommer.

Vi kan finne antall forekomster av en tekst i Excel. =Antalla teller celler med tekst, og andre verdier. For å finne antall med en bestemt tekst gjør vi:

=ANTALL.HVIS(B4:B15;E4)

Her skal vi finne hvor mange ganger Sko (E4) finnes i området vi har valgt (B4;B15)

Excel – Telle antall forekomster.

Vi kan finne antall forekomster i Excel, basert på 2 verdier. Der begge betingelsene stemmer, eller er sanne.

Skal vi finne hvor ofte både Sko og Jan forekommer samtidig bruker vi:
=ANTALL.HVIS.SETT(B4:B15;»Sko»;C4:C15;»Jan»)

Du kan legge til flere tester med Antall.Hvis.Sett. Først hvor du skal søke, og hva du skal søke etter. Så repeterer du den bortover.

Summer når teksten stemmer.

Ønsker du å finne ut hvor mye du har solgt av en vare, i en periode. Eller å finne antall fraværsdager per avdeling, kan du bruke denne metoden:

=SUMMERHVIS(B4:B15;»Sko»;D4:D15)

Vi summerer tallene i D4:D15, når vi finner Sko i cellene B4:B15

Summere celler med tekst.

Skal du summere tall, når flere celler med tekst stemmer. Finne antall salg basert på avdeling og måned. Da kan vi summere celler om teksten i flere celler stemmer:

=SUMMER.HVIS.SETT(D4:D15;B4:B15;»Støvler»;C4:C15;»Feb»)

Vi skal summere cellene D4:D15 hvis vi finner både Støvler i B4:B15, og Feb i området C4:C15

Summer tekst med flere betingelser.

En Excel-funksjon jeg ofte ramler ned på er denne, noen ganger kan det gjøres magiske ting med Summerprodukt, og betingelsene for å summere med tekst blir litt tuklete med de funksjonene vi har brukt over her.

=SUMMERPRODUKT((C4:C15=»Mar»)*1;D4:D15)

Her skal jeg summere hvor mye jeg har solgt i Mars. Den første delen, før semikolon, den tester om vi finner Mar i området som er valgt. Den testen returnerer enten SANN eller USANN. Siden vi ikke kan regne med tekst. Må vi lure Excel til å få tall. Derfor ganger vi med 1 (da får vi 0 eller 1).

D4:D15 er tallene som skal summeres om vi finner Mar.

Utvid kunnskapen, og kom i mål nå.

Jeg har 2 tilbud til deg.

By ghog Excel Share: